読者です 読者をやめる 読者になる 読者になる

Eclipse PluginはEclipse PluginであってOSGi Bundleじゃない!?

ってことですね。終わった。。。

独自の拡張が前提になってる、かつ、Equinoxに依存しちゃってたりするので、そのままじゃEclipse PluginはApatch Felixだと動かない・・・

要は、OSGi Bundleとしての定義を満たしてないってことですね。

まぁImportPackageにorg.osgi.frameworkを指定すれば解決しそうですが未確認><


そろそろEclipseのPluginがそのまま他のOSGi実装で動くような便利な仕組みとか出てこないかなぁ・・・w